RSGallery2 Support Forums
Welcome, Guest. Please login or register.

Login with username, password and session length
  Home    Forum    Help    Search    Login    Register  
News : October 28 07:41:32 AM
+  RSGallery2 Support Forums
|-+  RSgallery2 support forums
| |-+  RSgallery2 bugs & problems (Moderators: Jonah, Tomislav Ribicic, Daniel Tulp, Ronald Smit)
| | |-+  [GoDaddy install issues] RSG2 1.14.3 on Joomla! 1.0.13 install fails
Advanced search
  « previous next »
Pages 1 2
Sticky Topic Topic: [GoDaddy install issues] RSG2 1.14.3 on Joomla! 1.0.13 install fails  (Read 17654 times)
Reply #15
« on: May 03 04:11:25 AM »
joshua mcalpine Offline
Posts: 1

View Profile Email

trying something.
I noticed that the mysql dbases were different between two sites i had. one site was running mysql 4.1 and the other was running 5.0. the 5.0 was working easily.
I will try to update the site to 5.0 and will see if it works.

its not mysql 5.0, still did not work. i will try the other way listed above when i have more time.
« Last Edit: May 03 04:43:51 AM by joshua mcalpine » Logged
Reply #16
« on: June 12 01:04:49 PM »
Eric Donkervoort Offline
Posts: 4

View Profile Email

I too recieved a similar error I'm not on GoDaddy and I'm not on 1.0.13 but 1.0.15  after deleting the component directory and reinstalling the installation worked but there are a lot of database issues I cannot solve as I am no expert on either php or mysql.
Reply #17
« on: June 27 04:47:47 PM »
Jeff Rivett Offline
Posts: 5

View Profile Email

I'm also seeing this problem.  I can install any version up to 1.14 without running into this problem, but 1.14.0 through 1.14.3 produce this error.  Installs okay on my local test server.  Tried making the suggested PHP.INI changes (mysql.connect_timeout = 60, max_execution_time = 600, memory_limit = 36M) in my site's root (which does seem to override the Godaddy globals) but they made no difference.  I'm working with Godaddy on this and will post anything of interest.

My live site is on Godaddy:
PHP built On:  Linux 2.4.21-53.ELsmp #1 SMP Wed Nov 14 03:54:12 EST 2007 i686 
Database Version:  4.0.27-max-log 
PHP Version:  4.3.11 
Web Server:  Apache 
WebServer to PHP interface:  cgi-fcgi 
Joomla! Version:  Joomla! 1.0.15 Stable [ Daytime ] 22 February 2021 23:00 UTC 

My test server:
PHP built On:  Linux lamp 2.6.20-16-server #2 SMP Sun Sep 23 19:57:25 UTC 2007 i686 
Database Version:  5.0.38-Ubuntu_0ubuntu1.1-log 
PHP Version:  5.2.1 
Web Server:  Apache/2.2.3 (Ubuntu) mod_python/3.2.10 Python/2.5.1 PHP/5.2.1 mod_ssl/2.2.3 OpenSSL/0.9.8c mod_perl/2.0.2 Perl/v5.8.8 
WebServer to PHP interface:  apache2handler 
Joomla! Version:  Joomla! 1.0.15 Stable [ Daytime ] 22 February 2021 23:00 UTC 

UPDATE: GoDaddy says they can't help with application problems, which they've clearly decided is the case here.  I asked them about MySQL settings, since other people on these forums are speculating that the problem is there.  Meanwhile, it seems to me that if I can install any version prior to 1.14.x with no problems, but nothing from 1.14.0 onward installs without this error, something must have changed in 1.14.0 that is causing this.  I think it would be great if an RSGallery2 developer would dig into this a bit to see if maybe a change that appeared in 1.14.0 is causing this and could perhaps be reworked.  Others have speculated that 1.14.0 is making some invalid assumptions about Joomla (i.e. that it's 1.5, not 1.0.x).  Failing that, some specific recommendations regarding settings would be helpful.  Thanks!

UPDATE: Godaddy says there are no MySQL settings that can be set by the user; they are all global.  If it turns out I need to change a MySQL setting to avoid this problem I'll be looking at changing to a different hosting provider.

UPDATE: I seem to have resolved this by making the following changes to my Godaddy root PHP.INI:
mysql.connect_timeout = 120 (previously tried 60)
max_execution_time = 600 (did this earlier to no effect)
memory_limit = 36M (did this earlier to no effect)
max_input_time = 120 (hadn't tried this before)

Not sure what fixed it but I'm happy anyway.
« Last Edit: July 03 04:47:01 PM by Jeff Rivett » Logged
Print  Pages 1 2
« previous next »
Jump to: