RSGallery2 Support Forums
Welcome, Guest. Please login or register.

Login with username, password and session length
  Home    Forum    Help    Search    Login    Register  
*
News : October 14 02:39:47 AM
+  RSGallery2 Support Forums
|-+  RSgallery2 support forums
| |-+  RSgallery2 modules and plugins (mambots) (Moderators: Jonah, Tomislav Ribicic, Daniel Tulp, Ronald Smit)
| | |-+  RSGallery plugin for CB
Advanced search
  « previous next »
Pages 1
Author
Topic: RSGallery plugin for CB  (Read 16011 times)
« on: August 06, 2007, 11:58:54 AM »
bobby Offline
Newbie
*
Posts: 3

View Profile Email

I found this small plugin for RSgallery and CB and after the suggested modification to the .php file as found in the extensions comments (thanks devindash), I have it linked to my CB users which is great.  The problem I now have is the link for editing My Gallery items gives me the message "Unauthorized access attempt to My Galleries!".  Has anyone ran into this and if so, how did you fix the issue.

Thanks.
Logged
 
Reply #1
« on: August 24, 2007, 12:26:35 PM »
hyphenated Offline
Newbie
*
Posts: 21

View Profile

**bump**

I'd like to know too!
Logged
 
Reply #2
« on: September 03, 2007, 12:27:14 AM »
Brat Offline
Newbie
*
Posts: 3

View Profile Email

I had a similar problem with the CB plugin. Turns out that the URL constructors within the core file rsgallery2.plugin.php didn't build the links correctly. I made a very small change. I added the variagle $mosConfig_live_site to the global vars section of function ShowUserGalleries. Then, I edited each piece of code that generated a URL and added the live site variable. Fixed my problem.

Hope this helps someone.

Regards,
Brat.  Cool
Logged
 
Reply #3
« on: September 24, 2007, 07:51:14 PM »
bobby Offline
Newbie
*
Posts: 3

View Profile Email

Brat, I tried to implement the change you listed but I don't know enough about where to insert the variable.
Can you expand on your explination? 

Thanks.
Logged
 
Reply #4
« on: September 26, 2007, 04:41:55 AM »
PureMom Offline
Newbie
*
Posts: 5

View Profile Email

I would like to know as well please... Smiley  Also - please confirm that you are talking about this module or if you have found another one...

Thanks so much!
Logged
 
Reply #5
« on: September 26, 2007, 07:54:42 PM »
caplink811 Offline
Newbie
*
Posts: 3

View Profile Email

Hi,

yes, assuming that it is the plugin which Brat mentioned above..
Go and edit rsgallery2.plugin.php:

function ShowUserGalleries($user)
   {
      global $my, $database, $mosConfig_live_site, $Itemid;

.
.
.
...a href=\"".$mosConfig_live_site."/index.ph...

add the red one and add the blue one in each $htmlText line with index.php in it.

Just a remark, this plugin wont handle nested galleries.

bye
 JrB
Logged
 
Reply #6
« on: February 23 07:28:33 PM »
piersol Offline
Newbie
*
Posts: 2

View Profile Email

The plugin works fine for me, but it distorts my main content area over by about 20 or 30pixels creating an unpleasant layout.

Any reason why that would be? As soon as i unpublish it, the problem is gone. Any suggestions?
Logged
 
Reply #7
« on: February 24 12:14:12 AM »
baboon Offline
Newbie
*
Posts: 20

View Profile Email

The plugin works fine for me, but it distorts my main content area over by about 20 or 30pixels creating an unpleasant layout.

Any reason why that would be? As soon as i unpublish it, the problem is gone. Any suggestions?

i resolve it with this :

http://rsgallery2.net/component/option,com_smf/Itemid,17/topic,12762.0
Logged
 
Reply #8
« on: March 18 03:14:09 AM »
simondrew Offline
Newbie
*
Posts: 1

View Profile Email

Very basic installation question guys!!.....

I have installed the basic plugin for CB component (1.14.3) into Joomla (v1.0.12) which is already running CB.

After doing that, when I access the gallery from the web site, it just gives me a blank page. I presumed it may have something to do with this plugin since I am running CB. Problem is, I can't find where or how I'm supposed to install the plugin.

Can you help?

Thanks
Simon.
Logged
 
Reply #9
« on: March 28 10:12:09 PM »
Andreas Offline
Newbie
*
Posts: 1

View Profile Email

I use  RS Gallery 1.14.3 and Joomla 1.0.15 and CB 1.1, I cannot install the plugin throught CB plugin management. Can anyone help?
Logged
 
Reply #10
« on: May 27 10:08:17 AM »
v123shine Offline
Newbie
*
Posts: 1

View Profile Email

I use  RS Gallery 1.14.3 and Joomla 1.0.15 and CB 1.1, I cannot install the plugin throught CB plugin management. Can anyone help?

Same with me, cant somebody help us, Please!!!!!!!!!
Logged
 
Reply #11
« on: May 28 07:51:15 AM »
Marvin Offline
Newbie
*
Posts: 2

View Profile Email

The same problem @ my site: installed the actual version of RSGallery, the content plugin only renders the plugin text.

My configuration: Joomla 1.5.3 + DOCMan

Any ideas? thx
Logged
 
Reply #12
« on: July 02 02:05:39 PM »
ambshah Offline
Newbie
*
Posts: 1

View Profile Email

I installed the plugin as follows

1. unzip the downloaded the file
2. create a new index file index.html with a blank space. (installer wants this file)
3.zip the folder to a file named cb_rsg2.zip or any other zip file (the default will not work since it has a .380 in the file name.
4. install using the community builder installer.

Hope this helps someone
Logged
 
Reply #13
« on: July 12 06:31:02 AM »
shawn Offline
Newbie
*
Posts: 20

View Profile Email

Hello, post hijack here..

I installed Community Builder and lost the ability to see my RSgallery2 gallery when a user is loged into the front end. Does any of this discussion have anything to do with this? I cannot find and discussion topics on my need.

Thank you.
Logged
 
Reply #14
« on: July 20 01:15:27 AM »
aaron star Offline
Newbie
*
Posts: 1

View Profile Email

I am also having some issues with RS Gallery

I have managed to upload it perfectly fine. I am not sure what our friend was talking about in having issues, but I had none.

using Joomla 1.5 in legacy with CB 1.2 RC

ISUUE 1

HOWEVR, I have followed the advice in trying to integrate it with Community Builder as a plugin.

I went to think link to download the plugin   http://rsgallery2.net/nightly/misc/community_builder/

but everytime I tried to upload it, I get an error message saying the uload failed.

I have followed the thread in the forum in making this plugin work, and tried and failed.


ISSUE 2

I can not have users uloadc files because my media file's permissions block them from doing so.  I have tried to change my media files permissions with Joomla and am unable to.

Any suggestions?

Thanks
Aaron
Logged
 
Print  Pages 1
« previous next »
Jump to: