RSGallery2 Support Forums
Welcome, Guest. Please login or register.

Login with username, password and session length
  Home    Forum    Help    Search    Login    Register  
*
News : July 25 09:36:38 AM
+  RSGallery2 Support Forums
|-+  RSgallery2 support forums
| |-+  RSgallery2 bugs & problems (Moderators: Jonah, Tomislav Ribicic, Daniel Tulp, Ronald Smit)
| | |-+  [PHP 4 users][PENDING] Error installing a template. helper class missing?
Advanced search
  « previous next »
Pages 1 2 3
Author
Sticky Topic Topic: [PHP 4 users][PENDING] Error installing a template. helper class missing?  (Read 17378 times)
Reply #15
« on: February 26 07:03:12 PM »
Tom Puchner Offline
Newbie
*
Posts: 8

View Profile Email

Hi Jonah,
I originally posted in http://rsgallery2.net/component/option,com_smf/Itemid,14/topic,11842.0 - changed to this thread

I'm trying to install micromacro 1.7 but it doesn't matter - same problem with any template I'm trying to install.

By the way, when I first tried to install micromacro 1.7 I got the message "success" but it didn't show up in the rsgallery2 template manager. Now I found it next to my Joomla! templates...
Logged
 
Reply #16
« on: February 26 07:08:09 PM »
Jonah Online
Administrator
Hero Member
*****
Posts: 1398

View Profile

Hi Tom,

Upgrade to the latest nightly build.

Then install the microMacro template that is linked to at http://rsgallery2.net/content/view/92/62/

If you still have issues, include full details.
Logged

Due to time constraints, I have taken a step back from RSGallery2.  In the event of an emergency, you will need to PM me.
 
Reply #17
« on: February 26 07:09:30 PM »
Jon Offline
Newbie
*
Posts: 28

View Profile Email

Jonah,

Steps:
1)  Log in to site as super-admin
2)  Components/RSgallery2
3)  Template Manager -> Install
4)  Browse -- I'm picking up rsg2_superclean_0.5.zip  (just downloaded yesterday)
5)  Upload file and Install
6)  White screen with this error.  (The one I included above, repeated here since I see the thread split pages.)   This happens in about 3 or 4 seconds, it's rather quick.

Code:
Fatal error: Call to a member function on a non-object in /home/content/m/i/s/mistolpatch/html/administrator/components/com_rsgallery2/options/templateManager/helpers/JInstallerRSGTemplate.php on line 49

I'll PM you with backend access, if you want to check something out.

Am running PHP 4.3.11 on this site.   MySQL 5.0 (Client API version 5.0.18)

Joomla 1.0.13.
« Last Edit: February 26 07:12:06 PM by Jon » Logged
 
Reply #18
« on: February 26 07:19:20 PM »
Tom Puchner Offline
Newbie
*
Posts: 8

View Profile Email

Just installed com_rsgallery2_legacy._r669.zip
Then tried to install template rsg2_micromacro_1.7.zip

Error message:
Fatal error: Call to a member function on a non-object in /kunden/118886_1180/webseiten/joomla/administrator/components/com_rsgallery2/options/templateManager/helpers/JInstallerRSGTemplate.php on line 49
Logged
 
Reply #19
« on: February 26 08:42:23 PM »
Brooke Offline
Newbie
*
Posts: 8

View Profile Email

i'm using php 4.4.7
Logged
 
Reply #20
« on: February 26 09:36:57 PM »
Jonah Online
Administrator
Hero Member
*****
Posts: 1398

View Profile

must be a php4 thing then.  i should have a fix tomorrow for you guys.
Logged

Due to time constraints, I have taken a step back from RSGallery2.  In the event of an emergency, you will need to PM me.
 
Reply #21
« on: February 29 11:10:10 PM »
Brooke Offline
Newbie
*
Posts: 8

View Profile Email

just wondering if there was a fix yet.
thanks!
Brooke
Logged
 
Reply #22
« on: March 06 04:33:48 PM »
Jonah Online
Administrator
Hero Member
*****
Posts: 1398

View Profile

Ugh, sorry guys, I've been really busy.

As a temporary measure, just unzip the template zip file in components/com_rsgallery2/templates  that's all you need to do to manual install it.

i will reply again here when there is a fix for you all to try.  thanks for your patience!
Logged

Due to time constraints, I have taken a step back from RSGallery2.  In the event of an emergency, you will need to PM me.
 
Reply #23
« on: March 06 08:57:51 PM »
Jon Offline
Newbie
*
Posts: 28

View Profile Email

That didn't work for superclean.  (1) the folder names didn't quite match, easy enough to fix.  That done, (2)

Code:
Warning: main(/...components/com_rsgallery2/templates/superclean/display.class.php): failed to open stream: No such file or directory in /.../components/com_rsgallery2/templates/rsg2_superclean_05folder/index.php on line 14

Fatal error: main(): Failed opening required '/.../components/com_rsgallery2/templates/superclean/display.class.php' (include_path='.:/usr/local/lib/php') in /.../components/com_rsgallery2/templates/rsg2_superclean_05folder/index.php on line 14

superclean was looking for the folder rsg2_superclean_05folder, but the path for display.class.php is simply superclean.


Similar errors with micromacro.
Logged
 
Reply #24
« on: March 07 11:06:26 PM »
Jonah Online
Administrator
Hero Member
*****
Posts: 1398

View Profile

Ya, the folder names should just be the simple name of the template; superclean or micromacro, nothing else.  Try it again, it should work.
Logged

Due to time constraints, I have taken a step back from RSGallery2.  In the event of an emergency, you will need to PM me.
 
Reply #25
« on: March 09 06:36:18 PM »
Tom Puchner Offline
Newbie
*
Posts: 8

View Profile Email

Works fine for me, thanks  Grin
Logged
 
Reply #26
« on: March 11 03:25:18 AM »
Jon Offline
Newbie
*
Posts: 28

View Profile Email

Yep, that does the trick.

Although superclean is rather strange in that the image appears behind the thumbnails!
Logged
 
Reply #27
« on: March 22 03:45:45 PM »
Andy Offline
Newbie
*
Posts: 32

View Profile

Getting this error message when trying to upload templates
Fatal error: Call to undefined function: getclientinfo() in /share/storage/01/fr/frizzell/nmids/administrator/components/com_rsgallery2/options/com_installer/models/templates.php on line 55
Logged
 
Reply #28
« on: March 25 08:32:00 AM »
Andy Offline
Newbie
*
Posts: 32

View Profile

Okay, just manually installed templates and fixed permissions on subsequent directories using Mac OSX terminal in telnet mode but still no joy. same errors appearing.

FYI:
System information from my Joomla set up.

PHP Built on:    Linux ccgi03.plus.net 2.6.11-plusnet-cgi #15 SMP Wed May 25 18:26:16 BST 2005 i686
Database Version:    4.1.11-Debian_4sarge7-log
Database Collation:    utf8_general_ci
PHP Version:    4.3.10
Web Server:    Apache
Web Server to PHP interface:    cgi
Joomla! Version:    Joomla! 1.5.1 Production/Stable [ Seenu ] 8-February-2008 22:00 GMT
User Agent:    Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_4_11; en) AppleWebKit/525.13 (KHTML, like Gecko) Version/3.1 Safari/525.13

Hope that is of use to you. Should you require a test bed for nightly builds then I'm willing to give it a try. this web site is not a production site just yet.
To see it go to http://ccgi.frizzell.plus.com/nmids/ Click test gallery to see front end error 404 message.

RSGallery2 SVN is 720

Logged
 
Reply #29
« on: March 25 04:47:31 PM »
Andy Offline
Newbie
*
Posts: 32

View Profile

Okay here's my latest info on what I've been doing.

Had an hour to spare so uninstalled SVN 720 then uploaded 1.12.2 alpha. Hey presto gallery displayed until I clicked one of the thumbnails and an error 404 came up.

repeated uninstall and attempted to upload 1.14.3 and nothing, wouldn't upload and got time out error.
Ditto with an earlier 'nightly build' Same timeout error.

Decided to re upload SVN 720 Nightly build. All installed, however, I got this error 500 message:-

500 - An error has occurred

JDatabaseMySQL::query: 1060 - Duplicate column name 'user_id' SQL=ALTER TABLE `nmids_rsgallery2_comments` ADD `user_id` int(11) NOT NULL AFTER `id`

Call stack
#   Function   Location
1   jadministrator->dispatch()   /share/storage/01/fr/frizzell/nmids/administrator/index.php:67
2   jcomponenthelper::rendercomponent()   /share/storage/01/fr/frizzell/nmids/administrator/includes/application.php:130
3   require_once()   /share/storage/01/fr/frizzell/nmids/libraries/joomla/application/component/helper.php:162
4   installercontroller->execute()   /share/storage/01/fr/frizzell/nmids/administrator/components/com_installer/admin.installer.php:44
5   installercontroller->doinstall()   /share/storage/01/fr/frizzell/nmids/libraries/joomla/application/component/controller.php:239
6   installermodelinstall->install()   /share/storage/01/fr/frizzell/nmids/administrator/components/com_installer/controller.php:67
7   jinstaller->install()   /share/storage/01/fr/frizzell/nmids/administrator/components/com_installer/models/install.php:86
8   jinstallercomponent->install()   /share/storage/01/fr/frizzell/nmids/libraries/joomla/installer/installer.php:333
9   com_install()   /share/storage/01/fr/frizzell/nmids/libraries/joomla/installer/adapters/component.php:261
10   migrate_com_rsgallery->migrate()   /share/storage/01/fr/frizzell/nmids/administrator/components/com_rsgallery2/install.rsgallery2.php:38
11   migrate_com_rsgallery->handlesqlfile()   /share/storage/01/fr/frizzell/nmids/administrator/components/com_rsgallery2/includes/install.class.php:2117
12   migrate_com_rsgallery->runsqlfile()   /share/storage/01/fr/frizzell/nmids/administrator/components/com_rsgallery2/includes/install.class.php:1144
13   jdatabasemysql->query()   /share/storage/01/fr/frizzell/nmids/administrator/components/com_rsgallery2/includes/install.class.php:1175
14   jerror::raiseerror()   /share/storage/01/fr/frizzell/nmids/libraries/joomla/database/database/mysql.php:229
15   jerror::raise()   /share/storage/01/fr/frizzell/nmids/libraries/joomla/error/error.php:173
16   jexception->jobject()   /share/storage/01/fr/frizzell/nmids/libraries/joomla/error/error.php:138
17   call_user_func_array()   /share/storage/01/fr/frizzell/nmids/libraries/joomla/base/object.php:49
18   jexception->__construct()   

So back to the drawing board I guess. STATUS QUO here, hope this is useful. Delete it if it's not.

Andy.
 Roll Eyes
Logged
 
Print  Pages 1 2 3
« previous next »
Jump to: